CatFeeder/flake.nix

35 lines
882 B
Nix

{
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
nixpkgs-python.url = "github:cachix/nixpkgs-python";
nixpkgs-python.inputs.nixpkgs.follows = "nixpkgs";
devenv.url = "github:cachix/devenv";
devenv.inputs.nixpkgs.follows = "nixpkgs";
};
nixConfig = {
extra-trusted-public-keys = "devenv.cachix.org-1:w1cLUi8dv3hnoSPGAuibQv+f9TZLr6cv/Hm9XgU50cw=";
trusted-substituters = "https://devenv.cachix.org";
};
outputs = {
self,
nixpkgs,
devenv,
...
} @ inputs: let
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
in {
packages.${system}.devenv-up = self.devShells.${system}.default.config.procfileScript;
devShells.${system}.default = devenv.lib.mkShell {
inherit inputs pkgs;
# Import devenv shell modules
modules = [
./CCPP.nix
];
};
};
}